Resolved
All impacted services have now fully recovered.
Monitoring
We have applied the mitigation and are monitoring the recovery.
Monitoring
We have applied the mitigation and are monitoring the recovery.
Identified
We have identified that Plus and Pro users are experiencing elevated errors with the "Use connectors" tool and the tool may be inaccessible/unavailable for some users. We are working on implementing a mitigation.