Resolved
All impacted services have now fully recovered.
Identified
We identified the issue and the team is working towards a mitigation
Investigating
Starting around 6:45 AM PT on March 2, 2026, we began seeing elevated errors affecting file uploads and file processing. Some users may experience failures or delays when uploading files or while newly uploaded content is being processed. We are actively investigating and working to restore normal service. We’ll share another update within 30 minutes.