OpenAI

Codex unavailable
Resolved·Full outage

Codex is now fully recovered. All users should have full access, with all elements working as expected.

Tue, May 27, 2025, 10:48 PM
(1 day ago)
·
Affected components
Updates

Resolved

Codex is now fully recovered. All users should have full access, with all elements working as expected.

Tue, May 27, 2025, 10:48 PM

Monitoring

We have applied the mitigation and are seeing access and full functionality restored for users. We will continue monitoring the situation to ensure no further issues.

Tue, May 27, 2025, 10:08 PM(40 minutes earlier)

Identified

We have identified the root cause of the issue and are working to implement a fix.

Tue, May 27, 2025, 09:42 PM(26 minutes earlier)

Investigating

We are investigating an issue which has resulted in Codex on web being unavailable for all users. We apologize for the inconvenience and are working hard to restore access.

Tue, May 27, 2025, 09:37 PM
Powered by

Availability metrics are reported at an aggregate level across all tiers, models and error types. Individual customer availability may vary depending on their subscription tier as well as the specific model and API features in use.