Resolved
The issue has been resolved.
Investigating
We are currently investigating new reports of Pay-as-you-go API accounts receiving unexpected 429 errors. We will provide an update as soon as able.
Monitoring
Between approximately 9:00 AM PT and 9:00 PM PT on July 1, some Pay-As-You-Go and prepaid API accounts were mistakenly charged duplicate ledger deductions. This caused affected dashboards to show negative balances and led to unexpected "429 — usage quota exceeded" responses. Note that this did not impact Enterprise customers. We’re working to confirm the exact timestamps and will update when finalized. The issue is now resolved. Balances have been corrected and restored. We are continuing to monitor. If you manually added funds during this period to resolve a negative balance, we will automatically reimburse the excess within 7–10 business days. You can resume normal API usage. If you notice any lingering balance issues or 429 errors, please let us know. We apologize for the disruption and appreciate your patience while we worked to resolve it.