Resolved
All impacted services have now fully recovered.
Monitoring
We have applied the mitigation and are monitoring the recovery.
Identified
We identified the issue and are implementing a mitigation.
Investigating
We are investigating the issue where users report connectors disabled by admin, while they are enabled in Workspace Settings and are available for their group / role assignment.