Unexpected responses from ChatGPT
Incident Report for OpenAI
Postmortem

On February 20, 2024, an optimization to the user experience introduced a bug with how the model processes language.

LLMs generate responses by randomly sampling words based in part on probabilities. Their “language” consists of numbers that map to tokens.

In this case, the bug was in the step where the model chooses these numbers. Akin to being lost in translation, the model chose slightly wrong numbers, which produced word sequences that made no sense. More technically, inference kernels produced incorrect results when used in certain GPU configurations.

Upon identifying the cause of this incident, we rolled out a fix and confirmed that the incident was resolved.

Posted Feb 21, 2024 - 17:03 PST

Resolved
ChatGPT is operating normally.
Posted Feb 20, 2024 - 23:14 PST
Monitoring
We're continuing to monitor the situation.
Posted Feb 20, 2024 - 16:59 PST
Identified
The issue has been identified and is being remediated now.
Posted Feb 20, 2024 - 15:47 PST
Investigating
We are investigating reports of unexpected responses from ChatGPT.
Posted Feb 20, 2024 - 15:40 PST
This incident affected: ChatGPT.